Skip to main content

Curriculum Builder: Start Here

Need Help?

Students should seek assistance from a librarian by visiting the reference desk, calling (630) 617-3173, or IM'ing a librarian.

  • Your Blackboard username and password are the same as your technology account name and password.
    If you change your password on Blackboard, you are NOT changing your technology account password.

Faculty should consult with their Departmental Library Liaison for Blackboard assistance.

Additional Resources:

  • Limited, after-hours Blackboard Support for faculty and students - (844) 867-7321
  • Video tutorials from blackboard.  Closed Captioning is available in the lower right corner.
  • Find self-help at Behind the Blackboard.

Ebsco Curriculum Builder

Curriculum Builder is an add-on service from EBSCOhost  that enables customers to jump start their own reading list tool solutions by allowing easy and direct access to the world of quality databases, e-books, and other digital resources from your EBSCO databases.


Here’s how Curriculum Builder works:

  1. Search your library’s content from within the LMS
  2. Simply click “Add to Reading List” and your selections are saved
  3. Annotate reading list items and copy other reading lists created at your institution.*
    * Please note that the full text to which an institution subscribes is sometimes subject to unique conditions for use as course materials, and the guidelines for each must be followed, as appropriate.

 

 

 

 

System Requirements

1. Browser Choice

    Desktop OS
Browser Versions
             Mobile and Tablet OS
             Browser Versions*
Android Browser Not available 4+
Chrome                           36+ 35+
Edge 20+ 20+
Firefox 31+ Unsupported
Internet Explorer 11 Unsupported
Safari 6+ 6+
  • Microsoft announced it will only support Internet Explorer (IE) version 11 as of January 2016.  This means Microsoft will no longer address security vulnerabilities or other issues that may be identified with Internet Explorer 10 and older. 
  • Microsoft Edge do not support NPAPI-type plug-ins including Java plug-ins and many media browser plug-ins. Blackboard doesn't support these browsers for use with the Virtual Classroom and Lightweight Chat tools, the multiple-file upload interface, or embedded media that require NPAPI plug-ins for viewing.

Use the browser checker tool to check for compatibility and recommended software upgrades.

2. Devices & Operating Systems

Category

Tested

Operating Systems

Windows 7, Windows 8, Windows 10, MacOS 10.8, MacOS 10.9, MacOS 10.10, iOS, Android, Windows Mobile, Chrome OS

iOS Devices

iPod Touch , iPhone 4S, iPhone 5S, iPhone5c, iPhone 6, iPad 2, iPad 3, iPad Mini 3, iPad Air 2

Android Devices

Galaxy S4, Galaxy S5, HTC G1, LG C800 Mytouch, HTC One, Galaxy Note 2014, HTC One M8

Windows Mobile Devices

Venue 8 Pro, Lumia 520, Lumia 930

Chrome OS Devices

Chromebook

Note that mobile and tablet browsers for both Android and iOS are much better equipped to handle the Ultra Experience than the Original Experience. 

3.  Java Installation & Java Runtime Environment 7 & 8

 

4.  Third Party Plug-ins

  • You may require third party plug-ins to view certain content.
  • Check to see if you have the updated versions of Flash, Acrobat Reader, and Quick Time.

5. No longer supported by Blackboard:

  • Windows XP
  • Windows, MacOS, and Linux systems not running a supported browser
  • Internet Explorer versions 10 and lower which are no longer supported by Microsoft; Internet Explorer on mobile devices
  • Firefox versions 30 and lower on desktop; all Firefox versions on mobile devices
  • Chrome versions 35 and lower (version 34 and lower on mobile devices)
  • Safari versions 5 and lower
  • JRE 5 for Blackboard Learn Original user interfaces

The most current information on System Requirements for Blackboard Learn  can be found here.